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Introduction | Case Management Module Training Guide 
 

Preceding Training Guide 
• This training manual and links to FAQ’s for user self-help are 

available via My Dashboard > My Links > iConnect eLearning 
Library. 

 

 
Summary 
This training guide covers all aspects of clients enrolling into the 
DDMC Pilot Program along with documenting the Person-Centered 
Support Plan, HCBS Waiver Eligibility Worksheet and maintaining the 
client’s record. 

 
 

Learning Objectives for Case Management Module Training 
Guide: 
 Develop a working knowledge of the various components 

of a consumer record, and the navigation thereof. 
 Understand the function of roles within iConnect and how 

to use them with an established workflow. 
 Understand how to complete tasks associated with the 

user’s daily job responsibilities. 
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Chapter 1 | Developmental Disabilities Managed Care 
(DDMC) Pilot Program Enrollment 

 
Introduction 
This Chapter outlines the workflow from the point in time when a client 
on Pre-Enrollment is approved for iBudget Waiver enrollment or the 
Developmental Disabilities Managed Care (DDMC) Pilot Program. 

 
The process begins with steps completed externally to iConnect when 
the APD State Office team evaluates and makes a determination of 
Pre-Enrollment to iBudget Waiver Enrollment Eligibility. 

 
APD State Office will mail interest letters to eligible APD clients 
(combination interest letters for Pre-Enrollment clients in categories 3, 
4, and 5, who reside in the pilot counties and who are eligible for 
enrollment in the Managed Care Pilot and iBudget Waiver, iBudget 
Waiver letters for individuals in categories 3, 4, 5 statewide and pilot 
interest letters for individuals who are in Pre-Enrollment category 6 in 
pilot counties). Pilot counties include Hardee, Hillsborough, Miami- 
Dade, Manatee, Monroe, Polk and Highlands. Copies of these interest 
letters will be uploaded to a Note in the client’s record within iConnect. 

 
Regional Pre-Enrollment staff will identify individuals who are approved 
for iBudget Waiver enrollment in categories 1 and 2 in pilot counties 
that are age 18 or older. Once identified a notification is sent outside 
iConnect via the APDEnrollments inbox. State Office monitors the 
inbox to process interest forms, respond to inquiries, and region’s 
requests to send interest letters to individuals in categories 1 and 2. 

 
State Office staff will mail combination interest letters to individuals in 
categories 1 and 2 that are 18 years old or older and reside in pilot 
counties. State Office staff will update the client’s iConnect record by 
uploading the letter to a Note and updating their Pre-Enrollment status 
from “2 – Waiting” to “3 – Offered”. 

 
The individual submits the interest form by mail or email to the 
APDEnrollments inbox. 

 
State Office will date stamp interest forms for individuals accepting the 
offers and enter time of receipt on the master spreadsheet along with 
the individual’s response (acceptance or decline). 
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Chapter 2 |  iConnect Steps 

Document Combo Letter Sent /Update Pre-Enrollment Record 
Role: State Office Worker or State Office Enrollment 

State Office will monitor the APDEnrollments inbox daily to identify 
clients who need a “Combo Letter” mailed out, prepare combo letter 
packet and mail out immediately. 

1. State Office will upload each interest letter (those mailed out 
by State Office) to the client’s record in iConnect by adding a 
new Note record and updating the following fields: 

a. Division = APD 
b. Note Type = Waiver Enrollment 
c. Note Sub-Type = Offer Sent 
d. Description = Combo Letter, DD Managed Care Pilot 

Offer OR iBudget Waiver Interest Letter 
e. Status = Complete 
f. Attachment = Copy of Offer Letter 

2. When finished, click File > Save and Close Notes 
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3. Navigate to the client’s Pre-Enrollment tab in iConnect, 
open the existing Pre-Enrollment record and update the 
following fields: 

a. Pre-Enrollment Status = 3-Offered 
b. Pre-Enrollment Status Date = enter date 

 
 

 

 
4. When finished, click File > Save Pre-Enrollment and File > 

Close 

 
Document Interest Form Received 
Role: State Office Worker or State Office Enrollment 

As the interest forms are received: 
1. Date stamp all acceptance forms with postmark date and 

time 8:00am or date/time of email and enter the postmark 
date or email/date time the interest forms were received in 
the Master Tracking Spreadsheet for both, the DD Managed 
Care Pilot and the iBudget Waiver. 

2. If the client accepts either one of the programs, navigate to 
the Notes tab in the client’s record in iConnect. (If the client 
declines, proceed to step 7.) 
Add a new Note and update the following fields: 

a. Division = APD 
b. Note Type = Waiver Enrollment 
c. Note Sub-Type = Offer Response – Accepted 
d. Description = DD Managed Care Pilot Interest OR 

iBudget Waiver Interest 
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e. Status = Complete 
f. Upload the client’s acceptance document and click 

File > Save Notes 
 

3. Verify that the Questionnaire for Situational Information 
(QSI) is current. 

a. If the QSI is current, proceed to the next step. 
b. If there is no QSI or the QSI was completed more 

than 3 years ago, notify the Regional Clinical 
supervisor by email, request an expedited QSI 
evaluation, and enter the date the request for the QSI 
was made in the Master Tracking Spreadsheet. 

c. Once the QSI is complete, the Regional Clinical 
supervisor will respond to the original email to notify 
State Office that the QSI is complete. State Office will 
enter the QSI completion date in the Master Tracking 
Spreadsheet and proceed to the next step. 

4. Verify completion of the Home and Community-Based 
Services (HCBS) Waiver Eligibility Worksheet (coordinate 
completion with the Regional Pre-Enrollment Workstream 
supervisor, if needed) and track the completion in the Master 
Tracking Spreadsheet. 

5. Verify that the client has Medicaid. 
a. If the client already has Medicaid, proceed to the next 

step. 
b. If the client needs to apply for Medicaid, notify the 

Regional Pre-Enrollment Workstream supervisor by 
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email and request their assistance with guiding the 
client /legal representative through the Medicaid 
application process and sending the Form 2515 to 
DCF as part of this process. Notify APD State Office 
immediately when the client has been approved for 
Medicaid. 

c. State Office will provide DCF with a list of clients 
applying for Medicaid for assistance, as needed, and 
will track the Medicaid eligibility process in the Master 
Tracking Spreadsheet. 

d. Once the client has obtained Medicaid, then proceed 
to the next step. 

6. Navigate to the client’s Pre-Enrollment tab and update the 
Pre-Enrollment Status to “7-Removed PR” (“PR” = “Pilot 
Recipient”) (Do not change if person requests iBudget 
Waiver enrollment. This only applies to persons interested in 
enrolling in the DD Managed Care Pilot.) 

7. If the client declines either one of the programs: 
a. Navigate to the Notes tab in the client’s record in 

iConnect record, add a new Note and update the 
following fields: 

i. Division = APD 
ii. Note Type = Waiver Enrollment 
iii. Note Sub-Type = Offer Response – Declined 
iv. Description = DD Managed Care Pilot Declined 

or iBudget Waiver Declined 
v. Note = Explain client’s reason for declining the 

offer and indicate whether the client wishes to 
remain in Pre-Enrollment status. 

vi. Status = Complete 
vii. When finished, click File > Save and Close 

Note 
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b. If the client elects to remain in Pre-Enrollment, 
navigate to the Pre-Enrollment tab, open the existing 
Pre-Enrollment record, and update the following 
fields: 

i. Pre-Enrollment Status = 2-Waiting 
ii. When finished, click File > Save Pre- 

Enrollment and File > Close Pre-Enrollment 

c. If the client elects to be removed from the Pre- 
Enrollment, notify the Regional Pre-Enrollment 
Workstream Lead by email and request that they 
follow established closure procedures. 

 
If the interest letter is returned due to an incorrect address, State 
Office staff will follow normal contact procedures to determine if the 
case should be closed or if the address needs updating in the system. 
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Every interest letter response will be handled on a first-come-first- 
serve basis until the maximum number of enrollments has been 
reached. State Office staff will keep a record of the order in which they 
were received as described above for possible enrollment in the DD 
Managed Care Pilot or the iBudget Waiver. 

 
For individuals who meet the enrollment criteria for the DD Managed 
Care Pilot and are identified as such on the Pre-Enrollment record, the 
Data Unit will include all clients with a Pre-Enrollment Status = “7- 
Removed PR” in their daily file to the Florida Agency for Health Care 
Administration (AHCA) as an indication that those clients meet the 
criteria for enrollment in the DD Managed Care Pilot on the first of the 
next month. 

 
AHCA will send an auto assignment letter to the client once they are 
officially enrolled onto the pilot program and AHCA will provide APD 
State Office with the names of all clients enrolled in the DD Managed 
Care Pilot on a monthly basis. 

 
DDMC Coordinator is Assigned to Client’s Record 
Role: Role: State Office Worker or State Office Enrollment 

Once a DDMC Coordinator is assigned to a client, State Office will 
need to add a Program. 

 
1. Navigate to the client’s record and click the Program tab. Go to 

File and select Add Program. Update the following fields: 
a. Create Date = enter date 
b. Program = DDMC 
c. Disposition = Enrolled 
d. Disposition Date = enter date 
e. Enrollment Type = Enrolled in DDMC 
f. Primary Worker = choose the DDMC Coordinator 
g. Program Begin Date = enter date 
h. File > Save and Close Program 
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Role: State Office Enrollment 

Once the client’s record has been updated, the State Office Enrollment 
will update the Division tab of the client’s record. 

 
2. Navigate to the client’s record and click the Division tab and 

select the Division in the list view grid. Update the following 
fields: 

a. Primary Worker = DDMC Coordinator’s name 
b. Secondary Worker = Region Pre-Enrollment Lead’s 

name 
c. Disposition = APD Eligible – DDMC 
d. Disposition Date = enter date 
e. File > Save and Close Divisions 

 



DDMC iConnect Training Manual 

May 2025 Page 13 

 

 

UPDATED: Chapter 3 | Demographics and Contacts 
 

The Care Coordinator must ensure that the Consumer Demographics 
within iConnect are up to date. The Care Coordinator is responsible for 
entering, updating and ensuring the accuracy of all demographics and 
recipient-related information pertinent to the recipient in iConnect. 
Information includes recipient address, type of residence, living setting, 
legal representative name, and address (if applicable), employment 
information and type of benefits received. 
The Care Coordinator must update this information within 7 days of 
becoming aware of the change. 

 
Updating Basic Demographics 

 
1. To begin, log into iConnect and set Role = DDMC. Click Go 
2. Navigate to the Consumer Demographics record and click Edit > 

Edit Demographics 

 

3. The Consumer Demographics Details page is displayed. Update 
the following fields, as needed: 

a. Salutation = select the client’s salutation (Dr., Miss, Mr., 
Mrs., or Ms.) 

b. Alias = add the client’s alias when applicable 
c. Title = add the client’s title when applicable 
d. Gender* = select male or female 
e. Race = select the client’s race when known 
f. Ethnicity = select the client’s ethnicity when known 
g. Competency* = select the client’s competency 

i. Has been Adjudicated Incapacitated 
ii. Has Capacity 
iii. Incompetent, Guardian Available 
iv. Information not Available 
v. Legally Competent, Cannot Give Consent 
vi. Legally Competent/ Guardian Advocate Appt. 
vii. Minor 
viii. Minor Adjudicated Dependent 
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ix. Minor, Not Adjudicated Dependent, Parent 
Available 

x. Minor, Not Adjudicated Dependent, Parents 
Unknown 

h. Marital Status* = select the client’s marital status 
(Divorced, Married, Separated, Single/Never Married or 
Widowed) 

i. Living Setting* = select the client’s living setting (see list 
of definitions in Living Settings Defined) 

j. Medicare ID (required* if client has Medicare) 
k. Medicare Type (required* if client has Medicare) 
l. Demographics Verified On* = enter date the 

Demographics were verified. 

** Best Practice ** If there are no changes to the above listed 
Demographics, update the “Demographics Verified On” field at the time 
of the Support Plan to acknowledge that demographics are current and 
accurate. 
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4. Proceed to the next section to update the client’s contact 
information. If no additional information is needed go to File > 
Save and Close Demographics 

 
 

Updating Consumer Contact Information (ie. Addresses) 

5. If contact information needs to be updated, the Care Coordinator 
must delete the existing address and use all 6 clear buttons to 
remove existing data. 

 

6. Update the following fields: 
a. Address Type = The “Residence Address” must always 

appear here for ALL clients (waiver, pre-enrollment, 
DDMC Managed Care Pilot Program or other active) and 
must reflect the individual’s physical address. Allow 
iConnect to auto-populate as indicated. (For further 
instructions on how to fill out this section for clients 
without a permanent “Residence Address” (DDDP, ICF, 
jail, etc.) proceed to the “As Needed: Individuals without 
a Residential Address.”) 

b. Address = current residential address for client (use 
USPS standard Addresses, for ex. 1234 Felper Rd. or 
43210 W. End Ave.) 

c. Address 2 = leave blank unless Apt. or Suite is necessary 
d. Skip to Zip Code = type in current zip code and select the 

zip code in the selection menu when it appears 
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e. The following will auto-populate after entering the zip 
code. Verify that the information is accurate. 

i. City 
ii. State 
iii. County 
iv. Field Office 
v. Region 

 

*** Allow time for the address utility to provide the selection. Do not 
override the system. *** 

f. Main Phone = current phone number 
g. Business Phone = as applicable 
h. Extension = as applicable 
i. Cell Phone = current phone number 
j. Fax Number = as applicable 
k. Email = current email address 
l. Verified = click Verify 
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7. This is a valid USPS address so the record updates as valid and 
the date validated as today. 

 

8. Proceed to the next section to update the client’s Physical 
Description fields. If no additional information is needed go to 
File > Save and Close Demographics 

 
 

Updating Physical Description Fields 
 

9. Update the following fields: 
a. Written Language 
b. Spoken Language 
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c. Understood Language 
d. Interpreter Needed 
e. Medication Administration Capacity Date = leave blank 

 

10. Proceed to the next section to update the client’s Employment 
fields. If no additional information is needed go to File > Save 
and Close Demographics 

 
Update Employment Fields 

11. Benefit and employment information is required for all APD 
active clients (Waiver, PE, DDMC Managed Care Pilot, and other 
active). Update the following fields: 

a. Social Security Monthly Benefit Amount 
b. 3rd party Health Insurance? = select yes or no 
c. Competitively Employed? = select yes or no 

i. If yes, fill out the additional fields: 
1. Indicate Hire Date 
2. Average Monthly Earnings from 

Employment 
3. Hourly Wage 

d. Not Employed and Wants Competitive Employment = 
select yes or no 

i. If yes, fill out the additional fields: 
1. Phase of Employment Services Needed = 

Phase 1 or Phase 2 
2. Referred to VR? = select yes or no 

a. If yes, fill out the additional fields: 
i. Date of VR Referral 
ii. VR Response 
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12. Proceed to the next section to update the client’s mailing 
address, if their mailing address is different than their residence. 
If no additional information is needed go to File > Save and 
Close Demographics 

 
As Needed: Adding/Updating the Mailing Address 

1. If a client’s mailing address is different than the residence, an 
additional address must be included within the Consumer’s 
Demographics. Navigate to the client’s record and go to File > 
Edit Demographics. Click Consumer Address to open a list 
view grid of address listed for the individual. 

2. To enter the Legal Representatives,’ contact information proceed 
to “As Needed Adding Legal Representatives into Contacts Tab” 
section. 

 

3.  The Address page is displayed. Update the following fields as 
needed: 

a. Address Type = select Mailing Address 
b. Address = current mailing address for client 
c. Address 2 = leave blank unless Apt. or Suite is necessary 
d. Skip to Zip Code and enter the current zip code. Select 

the zip code that appears in the selection box. 
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e. The following should auto-populate after entering the zip 
code. Verify that the information is accurate. 

i. City = current city 
ii. State = current state 

*** Allow time for the address utility to provide the selection. Do not 
override the system. *** 

f. Start Date = start date of mailing address 
g. End Date = as applicable 
h. Active = check if Active 
i. Comments = as needed 
j. Address Valid 

 

4. This is a valid USPS address so the record updates as valid and 
the date validated as today. 

5. Once completed navigate to File > Save and Close. 
 

 
*** To deactivate a mailing address, navigate to the Consumer 
Addresses bookmark and uncheck the Active box. Once completed, 
go to File and select Save and Close. *** 
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As Needed: Adding Legal Representatives into Contacts Tab 

1. If the client has a legal representative or if there is a change in the 
legal representative, the Care Coordinator will make the necessary 
updates in iConnect. Navigate to the client’s record and click the 
Contacts tab. 

 

2. The list view grid will display showing the current contacts 
associated with the client’s record. It is important to note that the 
filters feature is automatically activated, and the list view grid will 
only show the Active contacts. The filters can be edited as needed. 

 

3. To add a new Contact, navigate to File > Add New Contact 
Search 

 

4. iConnect requires a search to be done to avoid duplication. Enter 
the Last Name and First Name of the Contact. Press Search. 
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5. The user has searched for an existing contact record but did not 
find a match in iConnect. A new contact record will be added. 
Select the Add New button. 

 

6. The Consumer Contacts Details page is displaced. Update the 
following fields as needed: 

a. Primary Relationship = Legal Representative 
i. Always use Legal Representative as the Primary 

when the client has a Legal Representative. 
However, if an adult client does not have a Legal 
Representative, please select the appropriate 
Primary Relationship that is not Legal 
Representative. 

b. Relationship(s) = select one of the following applicable 
relationships: 

i. Guardian 
ii. Guardian Advocate 
iii. Power of Attorney 
iv. Durable Power of Attorney 
v. Parent – If the consumer is a minor, the Primary 

Relationship should still be selected as Legal 
Representative and then Parent may be selected 
from the Relationship(s) menu. Do not select this 
option for adults from whom the parent is not 
the legal representative. 

vi. Medical Proxy 
c. Active Military Status 
d. Active 
e. Comments 
f. Last Name 
g. First Name 
h. Title 
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i. Legal Representative Organization 
j. Address 
k. Address 2 
l. City 
m. State 
n. Zip Code 
o. Main Phone 
p. Business Phone 
q. Extension 
r. Cell Phone 
s. Fax Number 
t. Email 

 

7. File > Save and Close Contacts. 
8. The Care Coordinator will then upload the legal documentation 

showing that the client has a legal representative if the client is not 
a minor or if the client is a minor, the legal representative is not 
their parents. 

9. The Care Coordinator will navigate to the Notes tab of the client’s 
record. 

a. In the Notes tab, go to File > Add Notes 
b. The Notes detail page will display. Fill out the following 

fields: 
i. Division = APD 
ii. Note By = defaults to worker’s name 
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iii. Note Date = today’s date 
iv. Note Type = Confidential Documentation 
v. Description = “Type of Guardianship” (Legal 

Guardian/Advocate/etc.) Documentation 
vi. Note = as needed 
vii. Status = Complete 
viii. Attachment = add the legal documentation of the 

client’s guardianship/legal representative. For 
further instructions on how to add an attachment 
precede to “Notes in iConnect.” 

 

c. File > Save and Close Notes 
 

As Needed: Adding New Contacts into Contacts Tab 

1. If the client has a new Contact, the Care Coordinator will make the 
necessary updates in iConnect. Navigate to the client’s record and 
click the Contacts tab. 
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2. The list view grid will display showing the current contacts 
associated with the client’s record. It is important to note that the 
filters feature is automatically activated, and the list view grid will 
only show the Active contacts. The filters can be edited as 
needed. 

 

3. To add a new Contact, navigate to File > Add New Contact 
Search 

 

4. iConnect requires a search to be done to avoid duplication. Enter 
the Last Name and First Name of the Contact. Press Search. 
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5. The user has searched for an existing contact record but did not 
find a match in iConnect. A new contact record will be added. 
Press the Add New button. 

 

6. The Consumer Contacts Details page is displayed. Update the 
fields as needed. 

 

7. File > Save and Close Contacts 
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Living Settings Defined 
Agency for Persons with Disabilities (APD) iConnect Living 

Settings Released 2/10/2020 

 
Please choose the appropriate living setting in iConnect 
based on the definitions below. 

AHCA Licensed Adult Family Care Home: A residential 
Adult Family Care Home designed to provide personal care 
services to individuals requiring assistance. The provider 
must live in the home and offers personal services for up to 
5 residents. 

AHCA Licensed Assisted Living: An Assisted Living 
Facility designed to provide personal care services in the 
least restrictive and most home-like environment. These 
facilities can range in size from one resident to several 
hundred and may offer a wide variety of personal and nursing 
services designed specifically to meet an individual's 
personal needs. 

AHCA Licensed Private ICF: A privately owned and 
operated Intermediate Care Facility in Florida. 

AHCA Licensed Nursing Home: A nursing home operated 
in Florida. 

APD Developmental Disabilities Center: A public 
Intermediate Care Facility, owned and operated by APD, at 
either the Sunland Center (in Marianna) or Tacachale (in 
Gainesville). 

APD Developmental Disabilities Defendant Program: A 
secure APD-operated residential facility (located on the 
grounds of Florida State Hospital in Chattahoochee or the 
Pathways program in Marianna) to which individuals are 
court-ordered for placement as a result of felony charges. 

APD Licensed Facility - Foster Home (Capacity 1-3): An 
APD licensed foster home with the capacity of no more than 
3 individuals. 

APD Licensed Facility - Large Group Home (Capacity 7- 
15): An APD licensed group home with the capacity of 7 to 
15 individuals. 
APD Licensed Facility - Residential Habilitation Center: 
An APD licensed facility which includes either the Duvall 
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Home’s Allgair Cottage in Volusia County or the United 
Community Options Hope Center in Dade County. 

 
APD Licensed Facility - Small Group Home (Capacity 4- 
6): An APD licensed group home with the capacity of 4 to 6 
individuals. 

DCF Licensed Home - Foster Home (Capacity 1 to 3): A 
foster home licensed by DCF with the capacity of no more 
than 3 individuals. 

DCF Licensed Home - Small Group Home (Capacity 4 to 
6): A facility licensed by DCF with a capacity of 4 to 6 
individuals. 

DCF Licensed Home - Large Group Home (Capacity 7 to 
15): A facility licensed by DCF with a capacity of 7 to 15 
individuals. 

DCF Commitment Facility: A forensic facility operated by 
DCF for individuals who are found incompetent to proceed 
on a felony offense or acquitted of a felony offense by reason 
of insanity, such as Florida State Hospital. 

Department of Juvenile Justice Facility: A residential 
program or detention facility for youth required by the court 
system to stay in the care of the Department of Juvenile 
Justice. 

Family Home: The primary residence occupied by the client 
and member(s) of the family including parents and siblings, 
including stepchildren, stepparents, stepsiblings and in-laws. 

Hospital – Non-Psychiatric: A hospital placement for 
medical treatment. 

Hospital – Psychiatric: A hospital placement for the 
purpose of treatment and the implementation of interventions 
to reduce symptoms of mental illness. 

Independent Living: A client’s own home where they live 
without Personal Supports or Supported Living Coaching. 

Jail/Prison: Incarcerated in a state prison or county jail. 

Supported Living: A client’s own home where they live and 
receive Personal Supports and/or Supported Living 
Coaching, and that home is available for lease or sale to 
individuals in the community. 
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As Needed: Individuals without a Residential Address 
How to add a Residence Address in iConnect for APD 
consumers without a Residence Address 

Below are instructions on how to document residence address 
and “home” Region for clients who are homeless or in a different 
Region at DDDP, in an ICF, jail, hotel, etc. iConnect is 
programmed to only show a “Region” designation when there is a 
“Residence Address” type. In the example below, the client is at 
DDDP in Chattahoochee with a “Temporary Address,” but his 
home region is Suncoast, so DDDP cannot be designated as the 
“Residence Address,” or it will incorrectly designate Northwest as 
his home Region: 

 

 
The details in the Consumer Address screen show that he has 
two “Temporary Addresses” (one for DDDP and one for the jail 
in Tampa). This client has no real residence address and no 
legal representative: 

 

 
When State Office runs reports his Region designation is blank 
because he does not have a “Residence Address”: 

 

Below are the instructions on how to document a “Residence Address” 
for someone who does not have one: 
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For clients with no home residence address and no legal 
representative: 

1. Add the Regional APD address as the client’s “Residence 
Address” 

2. Update the following fields: 
a. Address = enter the corresponding Regional Street 

Address 
b. Address 2 = enter the word: “Non-Residence” 
c. City = enter the Regional APD city 
d. State = FL 
e. Zip Code = “home” Region Zip Code 
f. Main Phone = enter APD Regional office main phone 

3. The correct “home” Region will show up in iConnect 

4. The “Residence Address” must be updated when (or if) a client 
moves into a more permanent living setting (such as family 
home, group home, own home, supported living, etc.) in the 
“home” Region. 

 
For clients with no home residence address who have a legal 
representative residing in the “home” Region: 

 
1. Add a “Residence Address” 
2. Enter the legal representative address 
3. Validate address as usual 
4. The correct “home” Region will show up in 

iConnect 
 

For clients with no home residence address who have a legal 
representative residing in another Region (or State) enter the 
Regional APD address as indicated in “A” above. 

 
Add as many “Temporary Addresses” as necessary and mark the 
client’s physical location as “primary. 
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Chapter 4 | Support Plan 

Introduction 

The Person-Centered Support Plan (PCSP) must be created in 
iConnect. Based on the Consumer/Legal Representative’s responses 
to questions in the QSI Assessment, iConnect uses Copy Shared 
Responses functionality to import QSI responses directly into the 
PCSP. The Care Coordinator will review the QSI responses and 
address those needs during person-centered planning. 

 
Once the Care Coordinator has completed the PCSP process, the 
PCSP will be created in a form in iConnect. 

Schedule the Support Plan 

Role: DDMC 

Upon enrolling the client into the DDMC Pilot Program the Care 
Coordinator will schedule the initial face to face meeting within 5 days 
of enrollment and begin the support planning process. 

 
1. Contact the individual to schedule the PCSP meeting and to identify 

PCSP participants. Document each contact in a Note in the client’s 
record. 

 
2. To do so, navigate to the Consumer’s record and click on the 

Notes tab > File > Add Note: 

 
3. In the new Note record, update the following fields: 

a. Division = APD 
b. Note Type = Support Plan 
c. Note Sub-Type = Pre-Support Planning Activities 
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d. Status = Complete 

4. When finished, click File > Save and Close Note. 
 

5. Upon identifying Consumer Participants, add them to the client’s 
record. Use “As Needed: Adding New Contacts into Contacts 
Tab” for further instructions. 

 
6. Upon identifying the client’s PCSP participants, reach out to 

invite them to participate in the PCSP meeting. Document each 
participant outreach attempt in a Consumer Note. To do so, 
navigate to the client’s record and click on the Notes tab > File > 
Add Note. 

a. In the new Note record, update the following fields: 
b. Division = APD 
c. Note Type = Support Plan 
d. Note Sub-Type = Pre-Support Planning Activities 
e. Status = Complete 
f. When finished, click File > Save and Close Note. 

7. Prior to conducting the Initial Support Plan/Support Plan meeting, 
the Care Coordinator will prepare the documentation. Care 
Coordinators will take a meeting signature sheet to the Initial 
Support Plan/Support Plan meeting with the client. A blank 
PCSP output report is printed. It will be filled out when face to 
face with the consumer and then keyed into the PCSP form in 
iConnect. 
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Create the Support Plan 

 
Role: DDMC 

1. To begin, log into iConnect and set Role = DDMC. Click Go. 
 

2. Navigate to the client’s record and click on the Forms tab: 
 

3. To add a new PCSP, use File and select Add Form. 
 

 
4. A new Form Details window displays. In the “Please Select 

Type:” dropdown, choose the Person-Centered Support Plan 
eff. 11/4/2021 
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5. Complete the header information. In the header of the form, 
update the following fields: 

a. Review = Initial 
b. Status = Open 

 
NOTE: There should be only one PCSP for the year. The Care 
Coordinator will leave the status = Open and make changes to the 
same form when there is an update vs. creating a new form each 
time there is an update. 

 
6. Information from other forms such as the QSI Assessment can 

be copied over into the PCSP record automatically using the 
Copy Shared Response functionality in iConnect. 

7. The Care Coordinator will select File > Copy Shared 
Response and select the QSI Assessment from the list of 
available forms. 

 

8. A list of Assessments with Shared Responses is displayed. 
Select the QSI form. 
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9. Once selected, the system will pull the information from the QSI 
to fill in the scores of the QSI section on the PCSP form. 

10. Please note that the PCSP in iConnect should be filled out in 
the same way as the hard copy PCSP. For questions related to 
what type of information should be included in the various 
sections of the PCSP, please refer to the Person-Centered 
Support Plan Training modules found on the APDcares.org 
website. 

11. Update all remaining fields. 
 

12. When finished, click File > Save and Close Forms. 

https://apd.myflorida.com/waiver/support-coordination/
https://apd.myflorida.com/waiver/support-coordination/
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Add Medication 
The Care Coordinator can add a medication in the Medication tab of 
the client record or add a medication from the PCSP form, which will 
go to the Medication tab of the client record. 

Add a new Medication from a Form 
 

1. To add a new medication from within the PCSP, the Care 
Coordinator will either add a new PCSP or open the existing 
PCSP. 

 

2. Medications are captured in the Medications tab of iConnect and 
can be added to the PCSP without the Care Coordinator re- 
typing the information. 

3. Care Coordinators can also add new medications from the PCSP 
form and the medication will be added to the PCSP and the 
Medications tab of iConnect. 

4. To add an existing medication from the Medication tab to the 
PCSP, select Search and a list of medications from the 
Medications tab of the client’s record will be displayed. Select the 
check box for each medication that needs to be added to the 
PCSP. Click ADD to insert the medication into the PCSP. 
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5. To add a new medication from the PCSP that will be added to 
the PCSP form and to the Medication tab, use the Medication 
Control on the PCSP form. 

6. In the My Health section of the PCSP form, select Add New 
Medication. 

 

7. The Medication search window opens. Begin typing the name of 
the medication. Matching values are displayed. Select the 
medication and complete the remaining fields. If the medication 
does not auto populate in search, type in “Other” in the 
Medication search. Select “Other” and then a new text box will 
display “Other Medication.” Type in the name of the Medication in 
the text box. 

 

8. Once complete, select Save and Close. The page will refresh 
with the medication information section completed. 

9. Save and Close the PCSP form. 
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Add Medication to the Medication Tab 
1. Navigate to the Medication tab on the client’s record. 
2. Go to File > Add Medication. 

 

3. Complete the Medication details page. 
 

4. If the medication does not auto populate in search, type in “Other” 
in the Medication search. Select “Other” and then a new text box 
will display “Other Medication.” Type in the name of the 
Medication in the text box. 
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5. When complete, select File > Save and Close Medication. 
Repeat this process for each Medication. 

 
 

Add Contacts 
Similar to adding the Medication, a Contact can be added into the 
Contacts tab or in the PCSP. When adding a Contact into the 
PCSP, that Contact will also be added to the Contacts tab. 

Add a new Contact from a Form 
 

1. In the PCSP, there are buttons that say Add New Relation and 
Search Existing Relations. To add a new relation, select the Add 
New Relation button. 

 

2. Enter the Name of the new contact in the text box as instructed. 
Change the Family Relation to Case Relation. Every Relation in 
iConnect is a Case Relation. Press Search. 

 

 
 

3. After the Search, a list view grid will appear. If there are no 
contacts with that name, select the Add New button. 

 

 
4. Fill out the New Relation as indicated. Choose the primary 

relationship from the drop-down menu titled “Relationship.” Once 
completed, press Save and Close. 
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Search an Existing Contact from a Form 
 

1. To add an existing contact to a form, select the Search Existing 
Relations button. 

 

2. Click the proper contact to add them to the form. 
 

 
3. The form will update with their information. 
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Complete the Support Plan Process 
 

There will be a second meeting with the client. The completed PCSP 
report output is printed from iConnect. The PCSP is signed by the 
client and added as an attachment to Notes in iConnect. 

To print the PCSP, navigate to the Forms tab. Open the PCSP form 
from the list view grid. 

1. From within the PCSP form, select Reports > Person Centered 
Support Plan. 

 

 
2. This will launch a new window. The Care Coordinator can either 

save directly to Note or save as pdf to their computer. Either 
option will give the Care Coordinator a printable pdf version of the 
PCSP to be used when gathering client/legal representative 
signatures. 
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3. If the Save to Note option is chosen, a Note window will launch 

with the pdf output listed as an attachment. Type in any additional 
information and click the Append Text to Note button. The signed 
signature page of the PCSP will need to be attached. Skip to step 
5. 
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4. Attach a copy of the signed PCSP to a Note in iConnect. On the 
client’s record, click on Notes > File > Add Note: 

 
5. In the new Note record, update the following fields: 

a. Note Type = Support Plan 
b. Note Sub-Type = Signatures 
c. Status = Complete 
d. Attach the signed Person-Centered Output Report to the 

Note record by clicking Add Attachment > Browse > 
select the appropriate file from your computer > Upload 

 
 

6. When finished, click File > Save and Close Note 
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Support Plan Update 

1. Throughout the PCSP year, the Care Coordinator may need to 
update the existing PCSP based on changes in the client’s 
needs or desires. The existing PCSP form will be 
amended/updated. A new PCSP form will not be created. 

 
2. The Care Coordinator will locate the PCSP form from the 

Consumer’s record > Forms tab and select the form to edit. 
 

3. The form must be in Draft, Pending or Open status to be 
editable. Forms in the Complete status are read only and 
cannot be edited. Forms in the Draft status are perceived to not 
be done and should only be used when in the drafting stages. 

 
4. Update the fields as needed. Click File > Save and Close 

Forms. 

5. Every time a form is saved, a snapshot of the form is saved in 
the History Records. Select File > History to review previous 
versions of the PCSP 

 
6. If more than one history record exists, click the Next or Last 

buttons at the bottom of the page to view each entry. 
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Annual Support Plan Review 

 
1. The PCSP expires after a year. The Care Coordinator 

usually begins the process 90 days in advance. 
 

2. Navigate to the client’s record and click on the Forms tab. 
Click the PCSP form with Status = Open. 

 

 
3. Care Coordinators should never utilize the same PCSP form 

year to year. However, some information may not change. 
While goals, needs, and other important factors must be 
reviewed and updated each year, Care Coordinators may 
use the Duplicate Assessment feature to copy information 
such as the social history. However, the Care Coordinator 
must update all sections of the PCSP with new information 
and change the effective date of the plan. 
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4. Click File > Duplicate Assessment. A notification window 
displays. Click OK. The new PCSP form that is a copy of 
the existing PCSP form will be displayed. 

 

 
a. In the Form header, change the Review Type = 

Annual 
b. Update the PCSP effective date. 
c. Make updates to goals, needs, and other important 

factors. 
d. When finished, update Status = Open 
e. Click File > Save and Close Forms 

 
5. The Forms list view grid displays. Select the existing 

(previous year’s) PCSP form. 
a. In the header, update the Status = Complete. 
b. Click File > Save and Close Forms 
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Chapter 5 | Level of Care 
 

Introduction 
Level of Care (LOC) assessments are completed by the Care 
Coordinator, to assist in determining if an individual meets eligibility 
requirements and to what level of service is required to accommodate 
the client’s needs. The Care Coordinator will utilize the HCBS Waiver 
Eligibility Worksheet to document the LOC determinations. The initial 
HCBS Waiver Eligibility Worksheet will be done by APD staff and 
thereafter the annual HCBS Waiver Eligibility Worksheet will be done 
by the Care Coordinator due in 365 days. 

 
Complete Waiver Eligibility Worksheet 

 
1. To begin, the Case Coordinator will log into iConnect and set Role 

= DDMC. Click Go. 
 

2. The client’s initial HCBS Waiver Eligibility Worksheet will be 
available by navigating to the client’s record and clicking on the 
Forms tab. 

 

 
3. To add a new form, annually, click Forms > File > Add Form and 

in the “Please Select Type” field select the HCBS Waiver 
Eligibility Worksheet 
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4. In the new HCBS Waiver Eligibility Worksheet, complete all 
relevant fields 

 
5. Update the fields in the header: 

a. Review = Annual 
b. Division = APD 
c. Status = Complete 

 
6. When finished, click File > Save Forms 

 
7. To print the form, navigate to the Word Merge menu and select 

HCBS Waiver Eligibility Work Sheet. 
 

 
8. The Word Merge will be displayed. Download and print the Word 

Merge to obtain the necessary signatures. 
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9. After obtaining the necessary signatures, attach the signed HCBS 

Waiver Eligibility Worksheet to the consumer’s record. To do so, 
navigate to the consumer’s record and click on Notes > File > Add 
Note: 

 
10. In the new Note record, update the following fields: 

a. Division = APD 
b. Note Type = APD Waiver Eligibility Verification 
c. Note Sub-Type = LOC Met/Medicaid Eligible 
d. Status = Complete 
e. Attachments = Signed HCBS Eligibility Work Sheet 

 
11. From the File menu > select Save and Close Notes. 
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Chapter 6 | Other Non-Waiver Eligible Settings – Admission 
 

1. The Care Coordinator or Pre-Enrollment Worker will document the 
client’s admission to a jail, nursing home, rehab center, hospital. To 
begin, log into iConnect and set Role = DDMC or Region Pre- 
Enrollment Workstream Worker. Click Go. 

 
2. Navigate to the client’s record and click on the Notes tab. Click File 

> Add Note. 
 

3. In the new Note record, update the following fields: 
a. Division = APD 
b. Note Type = Facility Placement 
c. Note Sub-Type = Consumer Admitted 
d. Status = Alert 
e. Enter details about the facility placement 
f. Then click File > Save and Close Notes 

 
4. Saving a Note with Note Type = Facility Placement and Sub Type = 

Consumer Admitted, triggers a Workflow Wizard with two ticklers 
for the secondary worker on the Division record: 

a. Change the living setting on the demographics page (due 
immediately) 

b. Verify Consumer to Remain on DD Managed Care Pilot (due 
in 60 days and visible via My Dashboard) 

 
5. Click the Change the living setting on the demographics page 

tickler to open the demographics list view page. 
 

6. From the Edit menu in the top toolbar > select Edit 
Demographics. 

 
7. Update the following fields: 

a. Living Setting = select applicable value 
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8. When complete, click File > Save and Close Demographics. 

 
9. Navigate to the client’s record to verify that the client is Medicaid 

eligible, and all other criteria have been met to enroll in the iBudget 
waiver. 

 
10. If the consumer will not remain in Pre-Enrollment or the DD 

Managed Care Pilot, the Care Coordinator will contact the Pre- 
Enrollment Worker (secondary worker). 

 
11. If the client will remain in Pre-Enrollment or DD Managed Care 

Pilot, send a note to the Pre-Enrollment or Waiver Workstream 
Worker (Secondary Worker). 

 
12. Navigate to the client’s record and click Notes > File > Add Note. 

 
13. In the new Note record, update the following fields: 

a. Division = APD 
b. Note Type = Facility Placement 
c. Description = Remains on Pre-Enrollment or DD 

Managed Care Pilot 
d. Note = enter details 
e. Note Status = Complete 
f. Note Recipient = search for and select the Pre- 

Enrollment or DDMC Care Coordinator. 
 

14. When finished, click File > Save and Close Notes 
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Chapter 7 | Safety Plan 
 

Introduction 
In some cases, clients exhibit behavior that indicates the need for a 
monitored plan of care. These behaviors include but are not limited to 
a documented history of engaging in sexual aggression, sexual battery 
or otherwise engaged in nonconsensual sexual behavior with another 
individual, with or without police involvement. A plan is needed to 
address their unique needs and create a safe environment for 
everyone and facilitate successful community living. In these 
instances, a Safety Plan developed by the Care Coordinator with 
consultation from the authorized behavior analysis (BA) provider or 
Area Behavior Analyst (ABA), when needed. These plans are 
integrated into the PCSP and implemented where the client resides. 
The following Chapter outlines how the Safety Plan should be 
documented within iConnect. 

 
1. To begin, the Care Coordinator will log into iConnect and set Role = 

DDMC. Click Go. 
 

2. Navigate to the client’s record and click on the Forms tab. Click the 
current Person-Centered Support Plan to edit. 

 
3. Navigate to the Personal Rights: (not related to guardianship) 

section of the PCSP. 
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4. Safety Plan required and included (if applicable choose Yes or No) 
= select “Yes” 

 

 
5. A new section of the PCSP will be displayed with information to be 

filled out regarding the Safety Plan. 
 

 
6. Fill out the necessary fields and once completed go to File > Save 

and Close Forms 
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Chapter 8 | Diagnosis – Mental Health and Medical Form 
 

Introduction 
In some cases, clients may have additional diagnoses. These are 
different than the original diagnosis that allowed the client to become 
eligible for DD Managed Care Pilot Program or the iBudget Waiver. To 
document the additional diagnosis, follow the steps outlined in this 
chapter. 

 
1. To begin, the Care Coordinator will log into iConnect and set Role = 

DDMC. Click Go. 
 

2. Navigate to the client’s record and click on the Forms tab. Go to 
File and select Add Forms. 

 

 
3. In the “Please Select Type:” dropdown menu, select Diagnoses – 

Mental Health and Medical 

4. Fill out the form header: 
a. Review = as applicable 
b. Status = Open 

 
5. Fill out the form. Use the ellipses to search for the diagnoses. 
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6. Utilize the search fields to locate the proper diagnosis. 

7. Once done, navigate to File > Save and Close Form. 
8. The form can be edited in Open Status. To make updates to the 

form, navigate to the client’s record and click Forms. The list view 
grid will display. Utilize the filters to locate the form. Press the green 
plus sign to add filters. 

 

9. In the drop-down menu, choose the appropriate form. 

 
10. Press Search 
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11.  The form will be displayed in the list view grid. Select the form to 
open. 
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Chapter 9 | Notes in iConnect 
 

Introduction 
Notes is a feature in iConnect that allows the user to upload 
attachments that are relevant to the client’s record such as a court 
order documentation of a legal representative. The following 
instructions will go over how to create a Note and how to mark a Note 
as Read if one is on the My Dashboard. 

 
Creating a New Note 
1. Once logged into iConnect, the Care Coordinator will navigate to 

the client’s record and select the Notes tab. 
 

2. The list view grid of all Notes created in the client’s record will 
display. To create a new Note, go to File > Add Notes. 

 

3. Fill out the Note fields as follows: 
a. Division = APD 
b. Note By = defaults to worker’s name 
c. Note Date = defaults to today’s date 
d. Note Type = choose the appropriate Note Type 
e. Note Sub-Type = choose the appropriate Note Sub-Type 

if needed. 
f. Description = as needed 

g. Note = as needed 
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h. Status = as needed (Do not leave a Note in Draft unless 
the Note is still being worked on. Notes should be in 
Complete Status if done or Pending Status if a response 
is needed or additional information needs to be added. 
Only use Alert Notes for Facility Placement as indicated 
in the workflow.) 

i. Add Attachment = Add any attachments as needed. Each 
Note can hold up to 10 attachments. If additional 
attachments are needed additional Notes can be created. 
The maximum size of the attachment is 18.46 Mbytes. 

i. To add an attachment, click the Add Attachment 
hyperlink. 

 

ii. Click Choose File to locate the document to 
attach to the Note. Files cannot contain 
special characters. 

 

iii. Select the file and click Open 
 

iv. To create a new name for the file, select the 
radio button “create new.” Type in the new 
name along with the extension. (i.e. .pdf, .doc, 
.docx, etc.) 
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v. A Description can be added if needed. 
vi. Click Upload if that is the only file or select 

Upload and Add Another to add additional 
attachments. 

 

vii. The attachment will be displayed in the 
Attachments Grid. 

 

viii. Add additional attachments as needed up to 
10. 

ix. To Remove an attachment, click the Remove 
hyperlink. 

 

j. Adding a Note Recipient to a Note will allow the Note to 
land on their My Dashboard. This is how to notify an 
individual in iConnect of information or actions needed. 
Note Recipients are only individuals in iConnect. To add 
a Note Recipient, follow the instructions below: 
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i. Click the Lookup button 
 

x. In the Search Text: add the recipient’s last 
name. Press Search 

 

xi. The list view grid of workers with that last name 
will display. Be mindful of the Title and if the User 
is active or not. If the User ID Active = No, do not 
select that worker. Click the appropriate worker to 
add them to the Note. 

 

xii. Their name will be displayed in the Note 
Recipients Grid. 

 

xiii. To remove a Note Recipient, click the Remove 
hyperlink. 

 

xiv. Repeat the steps needed to add any additional 
Note Recipients. 
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k. Once done, go to File > Save and Close Notes 
 

 
 
 

Marking Notes as Read 
Notes can be marked as Read from the Note itself or from the Note 
List View Grid. 

 
Marking Notes as Read from the Note 
1. Once logged into iConnect, the Care Coordinator will land on the 

My Dashboard. Under CONSUMERS there is a heading titled 
“Notes.” This will only display if there are Notes that the user has 
been added to as a Note Recipient and the Notes are not marked 
as Read. 

 

If the caret is pointing down, click the caret to show the 
Pending or Complete Notes. 
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2. Click the Pending or Complete under Notes. Once clicked, a list 
view grid will display all the Pending or Complete Notes. 

 
 

 
3. To view a Note, click the hyperlink to open the Note. 

 

4. The Note will display. If a response is needed (the user is only able 
to reply to a Pending Note, no edits can be made on a Complete 
Note), scroll to the Note section and in the New Text field, enter the 
needed text. Then press Append Text to Note. 
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a. After clicking Append Text to Note, a popup will 

display letting the user know that the Append Text to 
Note was successful and to save any changes. Press 
OK. 

 

b. The additional information keyed in will be displayed 
in the Note. 
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c. To send the response to the individual, the individual 

needs to be added as a Note Recipient in the Note. 
Note Recipients can only be users of iConnect. If the 
Note Recipient is already on the Note with a Status of 
Unread, they will not be able to be added back to the 
Note. If they are marked as Read, they will need to be 
added back onto the Note for the Note to display on 
their My Dashboard. 

 

d. Once completed with the Note, go to File > Save 
Notes. 

 
 

 
5. To mark the Note as Read, go to Tools > Mark as Read and 

Close. The Note will be off your My Dashboard, until added back 
as a Note Recipient. 
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Marking Notes as Read from the Note List View Grid 
1. Once logged into iConnect, the Care Coordinator will land on the 

My Dashboard. Under CONSUMERS there is the heading titled, 
“Notes.” 

 

2. Click the Pending or Complete under Notes. Once clicked a list 
view grid will display all Pending or Complete Notes. 

 

3. The checkboxes on the right can be selected individually or in mass 
by clicking the checkbox on the top. 

 

4. 
5. Once the proper Notes have been selected, navigate to Tools > 

Mark as Read. 



DDMC iConnect Training Manual 

May 2025 Page 66 

 

 

 

 

 
6. The Notes selected will be cleared from the My Dashboard; 

however, they will still be in the client’s record > Notes tab within 
iConnect. 

7. To close the Notes List View Grid, go to File > Close Notes. 
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Chapter 10 | Ticklers 
 

Introduction 
Ticklers are a feature in iConnect. The workflows for our DDMC Care 
Coordinators do not require Ticklers. If there is a Tickler that displays on 
the My Dashboard, the Care Coordinator can either Cancel or Complete 
the Tickler to get the Tickler off of the My Dashboard. 

 
Ticklers from Workflow Wizard 
Complete the following steps to remove any Ticklers: 
1. If a Tickler pops-up from a Workflow Wizard, simply navigate to the 

caret to display a menu option. 
 

2. Depending on the options that are available, select Cancel, Delete 
or Complete. 

 

3. Once the appropriate option is selected, the Tickler will be crossed 
out and deleted from the My Dashboard. 
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4. Once done, go to File > Save and Close Workflow Wizard 
 

 
Ticklers on My Dashboard 
Complete the following to remove any Ticklers from the My Dashboard: 

1. On the My Dashboard, navigate to the Ticklers menu under 
Consumers and click to open the list view grid. 

 
 

2. Once the list view grid is opened, navigate to the caret at the end of 
the record displayed. The pop-up menu will display. Select Cancel, 
Complete or the Delete option. 

 

 
3. Once selected, the Tickler will be removed from the list grid view. 
4. When all ticklers are deleted, go to File > Close Ticklers 
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UPDATED: Chapter 11 | Personal Disaster Plan Note 
 

Introduction 
The Care Coordinator will ensure that the Disaster Plan is current in 
iConnect for their clients and at least once a year, the Care Coordinator 
will upload the Disaster Plan as a Note in iConnect.  
 
Creating a Disaster Plan Note 
1. Once the Disaster Plan has been completed, the Care Coordinator 

will log into iConnect and set Role to DDMC. The Care Coordinator 
will navigate to the client’s record and select the Notes tab. 

 

2. The list view grid of all Notes created in the client’s record will 
display. To create a new Note, go to File > Add Notes. 

 

3. Fill out the Note fields as follows: 
a. Division = APD 
b. Note By = defaults to worker’s name 
c. Note Date = defaults to today’s date 
d. Note Type = Personal Disaster Plan 
e. Note Sub-Type = leave blank 
f. Description = as needed 

g. Note = as needed 
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h. Status = Complete 
i. Add Attachment = Add the Personal Disaster Plan 

 
j. Once done, go to File > Save and Close Notes 
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